Blog | Facebook | Contact      en  pl
Professional online survey tool
Help sections
FAQ

What web browsers are supported by mysurveylab?

mysurveylab.com supports following web browsers :

  • IE 11 or newer
  • FF 3.x or newer
  • Chrome 16.x or newer
  • Opera 11.x or newer
  • Safari 5.x or newer

NOTE. We are not supporting IE 6 and older versions of Internet Explorer. Download newest version of Firefox or Google Chrome, in order to use mysurveylab.com


Related pages